Cannot switch Core Module to bootloader

I’m trying to upload a custom built firmware to core module (R2.2) and I’m getting an error:

$ bcf flash --device COM4 ./firmware.bin
Cannot switch Core Module to bootloader, please check that the port is correct and it is not blocked by other application.

Flashing firmware from HARDWARIO Playground doesn’t work either.

I’m running it on Windows 10.

Please what could be wrong?

Thanks and Regards,

can you try to press and hold the button on Core Module before you start flashing. Hold it all the time until the module is flashed.
This is a workaround, let me know the results.

Can you try lowering the latency in VCP FTDI drivers?

Can you also try older Playground
Which other Playground versions did you try?

Hi Martin,
thanks for helping me.
Unfortunately none of the above worked.
Is there any way to debug it?

Thanks and Regards,

That’s weird.

Can you connect Core Module and run:
bcf devices -v

Can you try different computer? Are you sure COM4 is Core Module? Can you check that your micro USB cable is working properly by connecting other USB device to it?

Try just bcf flash from your project directory, it automatically selects firmware.bin and should show you all available serial ports. Please copy and paste the output.

Have you at least once sucesfully updated firmware in Core Module?
Was the Core Module bought as a preprogrammed kit or it was separate item?
What happens when you power up Core Module, what does the LED do? What the LED does after you press the button?
Could you try other Core Module?

Hi Martin,
here’s the output of bcf devices -v:

desc: Intel® Active Management Technology - SOL (COM3)
hwid: PCI\VEN_8086&DEV_8C3D&SUBSYS_17E010CF&REV_04\3&11583659&0&B3
desc: USB Serial Port (COM4)
hwid: USB VID:PID=0403:6015

I tried on two different computers with several USB cables.
Neither bcf flash command neither flashing firmware.bin from Hardwario Playground works. Here’s the bcf flash output:

0: COM3
1: COM4

I think I was able to flash the latest firmware from Hardwario Playground right after I connected it for the first time. However I’m not sure since everything was quite new to me and it’s been few weeks.

It was bought as a motion detection kit.

When I power it up the LED stays on for few seconds. Pushing the button causes the LED to blink. However only with brand new batteries. Strange thing is that I have already fourth pair of batteries since I bought it (less than one month ago). I always remove the batteries after working with it. Even though the batteries loose their power pretty soon.
Please check for details (sorry for the large file).
I tried a friends core module and it behaves differently. My core module is of version R2.2. My friends core module is R2.4. When I connect my friends core module to an USB cable the LED blinks 3 times. Also the LED blinks after the USB is removed when the button is pushed. This is different with my core module.
Another strange thing is that my friends module produces the accelerometer events while my doesn’t.

Thanks and Regards,

Hello Michal,

Triple blinking on oyur friends’ Core Module means that it has differt firmware, probably our testing because he might bought it separately and we do not flash any kit firmware there.

based on your video there is something strange with your Core Module. If I got it right based on your GIF then the module blinks and reacts to button, after USB connection it does not blink anymore which seems like some power switch electronics issue.

I’ll contact you over email to manage a replacement.