Change of Blynk


For a couple of years, I used Blynk / Node-Red together for my environment sensors. I have two modules (climate and outdoor) which send their data via Node-Red to Blynk.

Now it seems Blynk changed their business model, app, everything and I fear that at some point the old mobile app / service won’t work anymore.

Did anyone already migrate from old to new Blynk? It used to be rather easy - just tell Node-Red a URL + auth token where to send the data :slight_smile:

Kind regards

Hi, usually when something like this happens I type blynk alternative and go somewhere else.

Not sure if my next tip will be for you, but someone might find this useful what my current setup is:
I stopped using Blynk month ago (but not because of this, didn’t know this). What I do is the lowest cost VPS. I use Amazon LightSail that costs $3.50 USD/month. Then I have Wireguard VPN to my server/rpi at home. And all the Lightsail is doing is acting as a Proxy (nginx) to some of my node-red http endpoints. Nginx can also do basic authentication so you can secure your node-red dashboard, which could be used instead of Blynk.
For controlling stuff from Android launcher I use HTTP Shortcuts and its button widgets.

EDIT: The more secure variant is that you use just Wireguard and install it also to your phone. This way you have own secured VPN network and no need for nginx/proxy and not much secure http basic authentication. This way you use your VPN server just for a public IP/connecting

Thank you for the answer and your current setup.

I think I missed out a few key details (in my first anger about Blynk) - I mainly use it to track a few sensors from home. So basically, I want to watch the climate monitor data on my phone.

I could expose the Grafana installation to the internet - problem solved, but of course it is a higher risk (and more maintenance) and also lacks the UI friendliness of an app.

I am still open to further suggestions. Meanwhile, I will try to do something useful with my monthly €45 Azure budget. I guess someone already had a similar issue and tried to connect a sensor and Azure via MQTT. Maybe I write a Blazor app instead of a native app for my phone.