Change of prefix `bc_` to `twr_` in the SDK

Hello everyone,

our electronic building kit was renamed from BigClown Kit to Tower Kit and now we also changed SDK function prefixes from bc_ to twr_.

However you can still use bc_ prefix if you like, we kept them as the defines.


Right now the renamed functions have the same functions, same parameters. It’s just the prefix we have changed. The bc_ functions are defined here

Thanks to this define function and the same include name bcl.h your project will work properly even if you have older version of SDK and update SDK by calling make update from your command line.

For some time you will see older bc_ function names in documentation but we will slowly update them to the new twr_ however they have the same meaning.

When we add new functions to the SDK we might create only twr_ prefix names. So if you’re creating a new project we suggest to use the new twr_ prefixes.

You can easily replace bc_ to twr_ in VSCode using Search & Replace (Ctrl+Shift+H). You have to check the Preserve Case so the lowercase bc_ and uppercase BC_ will replace accordingly.
Also you have to select just app/* folder (this option will open if you click on three little dots ...)

Check in the list below if this is what you would like to change and click on Replace all (Ctrl+Alt+Enter).

Intellisense in VSCode will work fine, it will just show that the bc_ function will be changed to twr_gpio_init.