Connecting to Chester NB

Hi there,
I tried to connect to a Chester NB, following the Chester documentation. So far, I tried to use the Hardware Manager (iOS) and Hardwario Monitor (macOS). For the latter, I installed J-Link. However, I cannot find a bluetooth device for pairing and I am also unable to establish a connection via USB. How can I proceed to get the Chester working?
Thank you for your help!

I’ve managed to find out that you have units from Institute of Aquaculture and Protection of Waters, is this correct?

I would need more information to help you, since I’m not sure if you develop your own firmware or which revision of CHESTER you have.

  • Which hardware revision is your CHESTER? (photo is ok, we have older and current version of CHESTERs and I’m not sure which/when they were sent to you)
  • Which firmware do you have in the device? Is it one of the Catalog applications or your own?
  • Are you able to connect to the shell over JLink?
  • Can you share what is the output of the “info show” command? Please do not publish sensitive info like the passkey and claim token.

You can reply to support email if you don’t like to share sensitive information.

Hi there,
I sent you an email with a picture. I can confirm that the mentioned units are the ones I am holding in my hands. :slight_smile:

  • I do unfortunately not know which firmware is installed as I couldn’t find anything except for the white boxes in which the units were delivered. The initial firmware version not indicated anywhere as far as I can see. We also have a bunch of electrodes for water quality measurement, but I cannot find any catalogue firmware related to this online and I don’t know what past colleagues intended to do.
  • I installed the J-Link macOS package (J-Link SWO Viewer, J-Link GDB Server and J-Link Config) and it says it cannot find a USB emulator. The same message pops up when trying to connect via the Hardwario Monitor.
  • The output after info show is ProtocolInvalidOperationError

I might mention that I am currently using a MacBook with an USB-C to USB-A adapter and that I tried five different Micro-USB cables to be sure that this is not the problem.

Thank you for your assistance!