Core module not working on Ubuntu Xenial 16.04

Hello there,

I’ve just received two Core modules with Battery & Base module and few others today. Unfortunately I’m not able to get Core modules to work. I’ve seen the tutorial from your documentation although it doesn’t help me in this case.

I’ve tried to connect previously used Bridge module (from Alpha set) and it works. When I run dmesg it shows following messages when Brigde is connected:

[  968.077470] hid-generic 0003:0403:6030.0003: hidraw2: USB HID v1.11 Device [FTDI FT260] on usb-0000:00:14.0-1/input0
[  968.082148] hid-generic 0003:0403:6030.0004: hidraw3: USB HID v1.11 Device [FTDI FT260] on usb-0000:00:14.0-1/input1

Although no such messages are shown when I connect any of the Core modules. Do I need to do something beforehand?

Core modules seemed to be working, LED blinks when pressing the Boot button.

Some info about my computer (I didn’t used RPi for this first attempt, just my regular laptop):

$ cat /proc/version
Linux version 4.4.0-57-generic (buildd@lgw01-54) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4) ) #78-Ubuntu SMP Fri Dec 9 23:50:32 UTC 2016

Tomorrow I will try to connect it to my RPi when I have some free time…

Thanks for any clue about what could be wrong…

Btw. I’ve also noticed that Humidity tag R2.1 is not working with Bridge module. I was waiting for few minutes but it didn’t showed up in Dashboard.

yes bridge is connected as hidraw device, but node is connect over CDC.
Check /dev/ttyACM0 or /dev/stm32ACM0 .
The packages you have installed or used code from git repository ?

Humidity tag R2.1 has no support in bridge and dashboard, for now.

On raspbian we add udev rules

I see no such device.

I had not installed anything special, just plugged the Core module to USB and started docker container by this command:

docker run -d -p 8080:8080 -p 1883:1883 --privileged -v /dev:/dev -h hub-container --name hub bigclownlabs/hub

Ok, I’ve added bigclown group and user and udev rule to my machine like this

sudo addgroup --quiet --system bigclown
sudo adduser --quiet --system --home /dev/null --no-create-home --ingroup bigclown bigclown
sudo vim /etc/udev/rules.d/59-bc-workroom-stm32.rules
sudo udevadm trigger

Unplugged & plugged Core module back but nothing changed. No messages in dmesg.

bigclownlabs/hub works only with bridge,
you can use mqtt broker in this container with package for workroom project
how install on debian or raspbian look here
Be careful packages have dependency on mosquitto. If you can use mqtt broker from container disable mosquitto or remove, after install packages.

Ok, I’ll give it a try… But still shouldn’t I see /dev/ttyACM0 or /dev/stm32ACM0 on my system?

I had the same problem, so I wrote to the support and I got this answer:
Core module ordered as a separate component (not in the set) does NOT have firmware. After upload right firmware, you will see module as USB device.

Pavel Hübner promised to write documentation for this.

1 Like

That explains a lot :smiley: I do not have Core modules from the set :slight_smile:

@hubpav: Could you please let me know here when the documentation is ready? Until then my Core modules have to rest sadly on my desk :slight_smile:

@martin.grames: Have you been able to make it work according to my description?
@eggze: I have just forwarded to you the same instructions by email as I provided to Martin earlier today.

The official procedure is coming. I just feel a bit short-handed now but it is just around the corner :slight_smile:

1 Like

Thanks for the instructions and files. I’m able to flash the Core module with provided firmware but I’m getting following errors in dmesg:

[42734.408302] usb 1-1: new full-speed USB device number 11 using xhci_hcd
[42734.595195] usb 1-1: string descriptor 0 read error: -75
[42734.595214] usb 1-1: New USB device found, idVendor=0483, idProduct=5740
[42734.595221] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[42734.597929] usb 1-1: can't set config #1, error -71

Could it be related to the udev rule? I do not have much experience with udev, so it’s possible I’ve misconfigured it somehow. Is there any way how to debug udev (if the error is related to udev, of course).

Btw. when I press the B button the LED is toggled correctly (so firmware seems to be ok).

Another questions:

  1. Do I need different firmware binary for the Remote unit?
  2. And what about the tags from Alpha set, will they all work with those new Core modules?

Additional info: I can see the device when running lsusb.

Bus 001 Device 011: ID 0483:5740 STMicroelectronics STM32F407

Can you see /dev/ttyACM0 ? If yes, then virtual serial port has successfully enumerated. You can then open the serial port and print messages from it and see push button message being published with each press.

Sorry , I forgot to answer the other two questions:

  1. Yes, you need different firmware for Remote unit. You will have it later this afternoon in the official documentation. I will update this topic when it happens.

  2. From hardware perspective it is all compatible and all hardware we have released so far will be supported. Some of the tags are already implemented from Alpha Set (like Temperature Tag), some others are pending. Luckily we have Christmas time and I will be more focused on these things.

@hubpav: Strange, I wasn’t able to see /dev/ttyACM0 yesterday but now I see it.

screen /dev/ttyACM0 19200

works as expected.

So now, I would need to figure out how to read the data from sensors and how to connect the Remote Core module. Or should I rather start a new thread for it?

Oh, great news, thank you very much! :slight_smile: :thumbsup:

My use-case so far was to replace Alpha Set with those two Core modules (one in the function of former Bridge module and one remote in different room) but it seems it will require some additional work. Could you please guide me how to do it (I will create different thread for it)? I think it would be useful also for other guys here.

New topic is here.

Excellent, I have just published first Core Module tutorial. Still with many blank spaces but we have some starting point…

1 Like