GPS Module Initialization failed

I tried to use this example:

But after startup it shows Initilaization error in the log. I am using just GPS module + Core module without LCD display. I also tried to modify the example to don’t use display, but I am getting same error every time. The LED on the core module lights on permanently. Battery in the GPS module is inserted…

Do you have any idea what to try to identify where is the problem?

I also tried to:

  • update the SDK to latest version
  • change battery in GPS module
  • use another GPS module (I have two pcs of them)
  • create “super-simple” application.c which is used just for initialization of GPS module

but I am still getting the same error…

Because the error is based on result of GPS initialization function I don’t know what else I can check in my software.

I will appreciate any ideas what to try…


we are sorry to hear about the troubles you have. The ticket is acknowledged and we will do our best to make it work soon!

Unfortunately, I don’t have the GPS Module with me at home and I won’t get to the office until Monday to try this. Anyway, the repo you have tried should work as-is - we have been using it for tests.

I can tell, that almost certainly the problem is the Core Module is unable to connect with the I2C expander on the GPS Module.

  1. Could you please remove the battery and try again?
  2. Do you have a chance to take a detailed picture of the bottom side of the GPS Module?

Thank you very much. Cheers, P.

thank you for your response! It is absolutely OK that you can try something next week.

I tried to run it without the battery, but I had same result (error).

Here are the photos of my module:
IMG_3093 IMG_3088

If I can do something else (or take detailed photo of some part of the module), please give me a note…

Thank you

Hi Pavel,
may I do something more for investigating where can be the problem?


Hi Milan,
It looks like the problem might not be the GPS Module but something wrong with the I2C bus.

Could you try to initialize internal temperature sensor on the Core Module?

Please, try to use this repo:

If internal thermometer works, then we may experience an issue with the connectors.

Thank you. P.

1 Like

Hi Pavel,
your idea was absolutely correct!!! Because, I really found, that the connector was unattached to PCB for some pins. I have soldered it and it works! My soldering skills are not so good, but at this moment it works… I am sending you photo of soldered device (unfortunately as I was so surprised, I have forgotten to take a photo of situation before the soldering). You can check if theese pins are really used for GPS module. It is the first time when I saw something damaged on the devices.
Thank you very much for your help. Now it is up to me to make it work…


IMG_3124 IMG_3125

Dear Milan,
first, we are glad to hear you made it work!

I am truly sorry we have delivered a board with poor distribution of the soldering paste. The connectors are assembled using the automated pick and place machine and soldered in the reflow oven. For paste distribution on connector pads, we actually use thicker stencil (in order to deliver more paste on the pad). Since this precaution, we have not had a single report of failure on sockets, until now :slight_smile: Most likely, this is a result of bad luck on the particular piece, but we take full responsibility for that.

We treat such things very seriously and we are now discussing measures to avoid such situation happening in the future again.

Yep, it would be better to have pictures before your hand soldering, but Ctrl+Z has not been back-ported into a real life yet, unfortunately… :wink:

Thank you for the cooperation and helping us identifying the defect.

Have a nice day. P.