Playground on Raspberry Pi launch issue

I’ve just bought my first raspberry and hardwario kit and I’m not able to launch the playground. I followed the tutorial but then I get to step “download installation file” where I’m not sure which Linux/Ubuntu version should I get for the raspberry. So I tried all of them but I’m not able to launch it.

Can you please give me step-by-step on how to do it? Which file should I get and how to extract/launch the playground GUI then?

Thank you🙏

Hi, which files have you tried to download and flash?
Steps are explained here
Download the buster lite (which is smaller and does not have GUI desktop)

For RaspberryPi you need HARDWARIO Raspbian which is a webpage you connect from you computer to the Rpi IP.
For your computer you need HARDWARIO Playground.

I did flash the to my Rpi, I can connect to it from my macbook via ssh, even connect to virtual desktop via VNC. All seems configured well, I can even start Node-RED.

Now I want to open the Playground. Since the dongle is connected to Rpi, I thought that I have to install the Playground on it and connect via VNC to work with it from my mac.

Just boot the HARDWARIO raspbian on Rpi and enter Rpi IP to your web browser.

HARDWARIO Playground is application for computer only when you would like to use Radio Dongle coneted in your computer’s USB.

1 Like

Thanks! I did not expect it to be that easy. Can you maybe give me a hint in the next step? I’m in the playground now but it seems it does not see the dongle. But I can list it via bcf devices… any idea?

True is, that I accidentally followed all steps in since it is just right after the “Raspberry Pi Login” section. Maybe I did something wrong by doing this and have to re-flash it?

What does it mean exactly?

Try boot Rpi with dongle already connected.

Please use word raspian if you mean Raspberry Pi webpage, since Playground is really a Desktop/gui software.

On the raspian site it shows this warning message.

I did reboot it with the dongle connected. I will try to start all over again later today when I get to the device physicaly. Now I have only remote access.

Thanks for screenshot. The reboot with connected Dongle should fix that.

So I moved a little bit further. I did re-flash it with HARDWARIO raspian again, did update & upgrade, launched VNC and connected to raspian website, also used sudo usermod -a -G dialout $USER command. Now I can see some push-button (where does this come from?) but I dont see the “Home” tab or tab for Firmware update.

HARDWARIO raspbian (formerly BigClown HUB) does not have Home or Firmware tabs. Please use HARDWARIO Playground on your computer to flash Core Modules.

1 Like