[SOLVED] Lora-Tester - GPS problem after wakeup

the GPS module does not work as expected in the Lora-Tester Firmware.
After putting the Lora-Tester to sleep, the GPS does not show Satellites or a Fix after wakeup anymore. To simulate the problem do the following:

  • Power on the Lora-Tester with Batteries
  • Enter the GPS menu and wait for a Fix (1) and the number of Satellites found (e.g. 7)
  • Put the Lora-Tester into sleep mode via Display Buttons
  • Wait a few minutes
  • Wakeup the Lora-Tester with the left button
  • Enter the GPS menu and wait for Time, Date and Location
  • Notice that the Fix is 0 and that the Satellites are 0 too.
  • I’ve not checked any serial output
  • Tests were made outdoor

Could you please fix this?

Thanks in advance

Big thanks to @martin.grames for fix (Pullrequest)

It’s weird because on my kit it worked. I really tested a lot that sleep feature including current consumption and GPS wake-up.

@Peter, could you please test this release? It may take day to appear in Playground but you can download binary from link below and choose to flash this binary file from disk.

Please let us know if this fixed the issue.

Hi Martin,
i can confirm that the new Firmware is working as expected. After waking up and a sync cycle, the number of Satellites and the Fix Quality are working as expected.

Nevertheless, I saw yesterday evening that the date is not shown correct. I’ve not checked it deeper yesterday, but the date is printed as 0019-08-14 on the LCD for example. Shouldn’t it be 2019-08-14?

Furthermore, I have a feature request.
After sleeping the LoRa-Tester, the GPS Module needs up to five minutes to sync again. Is it possible to use the Standby Mode of the GPS receiver to allow quicker fixes?

Thanks and best regards


thanks for testing the new version.

Thanks also for reporting new issues. We’ll fix both issues in a few days. If you would like to test the fix now, you can follow instructions below.

The new GPS Module R1.2 has conencted backup power to GPIO expander pin P7. So if you open SDK and GPS init and enable output and logic HIGH on P7 it should work.

bc_tca9534a_write_pin(&_bc_module_gps.tca9534, BC_TCA9534A_PIN_P7, 1);


Hi Martin,
sorry for the delay. Where can I find the source code of the Lora-Tester to add the needed “Backup Battery” solution?


Hello Peter,

it’s in our second github organization called bigclownprojects

Clone the repository compile it by make and the SDK subrepository is cloned. Then find the bc_gps files and you can try the fix.

However I plan to fix it today with GPS year bug. I let you know when the new binary will be ready.

Developers portal github page:

Hi Peter,

the new version v1.0.3 is out. Can you please test it?

Just please also confirm to me that you have GPS Module R1.2.

New binary

Original pull request

Hi Martin,
I can confirm that I have GPS Module R1.2 and that the new firmware 1.03 is working as expected.
Thank you very much!

Best regards

1 Like