[SOLVED] Radio communication from USB Dongle to Remote

I’m testing USB Dongle with remote unit (Core + LCD modules - powered by usb).

I flashed bcf-usb-dongle fw into USB Dongle. What fw I need flash to Remote to allow radio control - switch LED on remote on/off, write text on remote? I’ve tried bcf-generic-node-battery-standard, but it does not work. It looks like, it should work with the POWER_MODULE enabled FW, but it does not work as well.

I can see sensor values in mqtt-spy, but I’m not able to sent any command. There are no examples in https://github.com/bigclownlabs/bcf-usb-dongle but I think commands from https://github.com/bigclownlabs/bcf-usb-gateway should works on Dongle as well. Or I’m wrong?

Received messages:

node/836d19820e43/hygrometer/0:4/relative-humidity 62.6
node/836d19820e43/push-button/-/event-count 9
node/836d19820e43/push-button/lcd:right/event-count 9
node/836d19820e43/lux-meter/0:0/illuminance 75.2
node/836d19820e43/hygrometer/0:4/relative-humidity 65.5
node/836d19820e43/push-button/-/event-count 10
node/836d19820e43/push-button/lcd:right/event-count 10

What I tried to sent:

$ mosquitto_pub -t 'node/836d19820e43/led/-/state/set' -m '{"state": true}'
$ mosquitto_pub -t "node/836d19820e43/lcd/-/text/set" -m '{"x": 5, "y": 10, "text": "BigClown"}'

It was published, but probably not received by Remote:

$ mosquitto_sub -v -t '#'
node/836d19820e43/hygrometer/0:4/relative-humidity 67.2
node/836d19820e43/lcd/-/text/set {"x": 5, "y": 10, "text": "BigClown"}
node/836d19820e43/hygrometer/0:4/relative-humidity 66.1

Yes, commands for dongle it same as commands for usb-gateway.
It is also written there:
Commands can be sent only to nodes powered by the power module, or usb-gateway.

bcf-generic-node-battery-* send only data, does not accept commands for now.

Ok, but I also flashed POWER_MODULE fw (bcf-generic-node-power-module-xxx) and i did not work. But I don’t know, if it should work without power module.

I also tried move radio related code outside POWER_MODULE parts, but did not work as well. And I’m not sure, where I did the mistake.

in sdk there was a bug with an eeprom, it did not have to heal to pair in both directions, I recommend downloading the current firmware or git pull and make update. This also applies to dongle.
Remove node and pair again.

not necessary power module

Great. Will check evening. Thanks

EDIT: just to be sure, what is exact pairing process? Maybe I did it wrong.

So tested and It works now. I can (with power module fw) control LED and text on LCD. Thanks for help.